Installer Exchange 2007 sur Windows 2008 -> problème à l’installation, Outlook Anywhere,IPV6

Salut à tous

J’ai participé à un projet de déploiement d’Exchange 2007 SP1 sur Windows 2008.
Inutile de vous dire que cela a été du sport.

En effet une des grandes nouveautés de Windows 2008 est la refonte de la pile TCP/IP et l’intégration du protocole IPV6.
Nous allons voir que cela pose au moins deux problèmes avec Exchange 2007 :
* Un problème lors de l’installation d’Exchange
* Un problème avec Outlook Anywhere

Le premier problème se pose quand on essaie d’installer Exchange 2007 sur un serveur Windows 2008 et que l’on a désactivé IPV6 au niveau de ce serveur.
On rencontre alors l’avertissement suivant lors des tests de préparation du programme d’installation de Microsoft Exxhange Server 2007 SP1 « Avertissement. Le programme d’installation n’a pas pu détecter de connecteur SMTP ou d’envoi avec un espace d’adresses de « * ». Il se peut que le flux de messagerie vers Internet ne fonctionne pas correctement ».
Si l’on clique alors sur « Installer », l’installation du rôle « Transport Hub » va échouer avec l’erreur suivante : « Erreur : Le service « MSExchangeTransport » n’est pas parvenu à atteindre l’état « Running » sur ce serveur. »
Le premier message est documenté par Microsoft :
http://technet.microsoft.com/en-us/library/ aa997285(EXCHG.80).aspx
Le second est expliqué ici :
http://forums.microsoft.com/TechNet/ShowPost.aspx? PostID=2863496&SiteID=17
En gros il faut laisser le protocole IPV6 activé et l’installation se passe bien alors.

Le second bug, topujours aussi amusant avec Outlook Anywhere :
Le problème est assez vicieux.
En fait on le rencontre quand on veut publier Outlook Anywhere (de préférence avec Isa SErver 2006).
En effet, en local Outlook Anywhere semble focntionner mais on arrive pas à établir une connexion distance.
En fait Outlook Anywhere ne fonctionne ni en local ni à distance.
Quand on vavoir dans l’état de la connexion d’Outlook (lancer Outlook, appuyer sur la touche CTRL et faire un clic droit sur l’îcone d’Outlook en bas à droite dans le menu démarrer).
On doit alors voir dans la fenêtre Etat de la connexion Microsoft Exhange, plusieurs lignes qui correspondent aux différentes connexions nécessaires pour le fonctionnement d’Outlook Anywhere avec comme type « Répertoire » ou « Courrier ». Le champ « Connexion » de chaque ligne doit être sur « HTTPS » et non sur TCP / IP. Si une des connexions est en TCP/IP, Outlook Anywhere ne fonctionne pas correctement et vous allez rencontrer des problèmes en essayant de le publier.
Ce problème semble uniquement se poser si vous avez installé les rôles Mailbox, CAS et Transport Hub sur le même serveur Exchange 2007.

Encore une fois, c’est IPV6 qui pose problème. Au point que Microsoft vous conseille de désactiver IPV6 quand Exchange 2007 est installé sur Windows 2008 Server (il faut aussi modifier votre fichier HOST et créer la clé DisableComponents).
Pour plus d’informations, voir articles suivants :
http://msexchangeteam.com/archive/2008/ 06/20/449053.aspx
http://technet.microsoft.com/en-us/library/ cc671176(EXCHG.80).aspx
http://www.digwin.com/view/outlook-anywhere-is-broken -on-ipv6-in-windows-server-2008
http://blog.aaronmarks.com/?p=65
http://exchange-genie.blogspot.com/2008/ 02/configuring-outlook-anywhere-for.html

A+

À propos de Guillaume Mathieu

Consultant - Formateur chez PROSERVIA (Pôle Conseil Expertise)
Ce contenu a été publié dans Bug, Exchange, IPV6, Troubleshouting. Vous pouvez le mettre en favoris avec ce permalien.

7 réponses à Installer Exchange 2007 sur Windows 2008 -> problème à l’installation, Outlook Anywhere,IPV6

  1. max dit :

    Merci pour ce commentaire, c’était la source de mon problème.

  2. Cris dit :

    Merci pour votre post, il m’a bien aidé à configurer mon serveur.

    Il m’a mis sur la piste pour des soucis de Backup.
    Je n’arrivais pas a Backuper mon Exchange 2007. Le souci provenait aussi d’IPv6.
    En le désactivant tout est rentré dans l’ordre.

    J’ai :
    - désactivé IPv6 sur les cartes réseaux,
    - modifier le fichier host
    - crée la clé de registre HKEY_Local_Machine\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters

    Donc source du souci différent mais même remède.

    Merci.

  3. Merci beaucoup pour ce retour.
    IPV6 est source de bien des problèmes….
    Bon courage pour la rédaction de votre Cahier des Charges…
    a+

  4. Gaëtan G dit :

    Impec !
    merci pour ces info, je ne comprenais pas non plus pourquoi Exchange ne voulait pas s’installer.
    C

  5. Gaëtan G dit :

    Merci des ces info ! Exchange s’installe maintenant dans ma maquette.
    le déploiement de l’IPv6 promet !!

  6. Thierry DEMAN dit :

    La désactivation de TCPIP V6 est tout à fait salutaire au bien de Exchange 2007, c’est clair.

    En revanche, que les connexions se fassent en TCPIP au lieu de HTTP/S n’est pas du tout un problème. Cela veut simplement dire que le client Outlook privilégie l’accès direct (TCPIP) quand il le peut.

    A+
    EXCHANGE MVP.

  7. david dit :

    merci!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*


huit − = 7

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>